..und Google machts richtig!

As of August 1st, we will discontinue support for the following browsers and their predecessors: Firefox 3.5, Internet Explorer 7, and Safari 3. In these older browsers you may have trouble using certain features in Gmail, Google Calendar, Google Talk, Google Docs and Google Sites, and eventually these apps may stop working entirely.

http://googledocs.blogspot.com/2011/06/our-plans-to-support-modern-browsers.html

Hoffentlich bewegt das mehr Leute und auch Systemadministratoren, auf neuere Browsergenerationen zu setzen. Aus der Debian-Ecke hab ich dazu auch einen netten Blogpost gefunden, den will ich euch nicht vorenthalten:

Such a decision denotes a grave misunderstanding of the workstation ecosystem from the Google people. It means they consider their only target to be nerdy users with home computers they can (and want to) upgrade and break every 3 months with the latest version of Windows or Fedora. What about corporate computers? What about non-techy people who buy a computer and stick with the OS that was sold with it for 4 years? I’m afraid they are still the vast majority of web users. You can’t decide to deploy a new version of IE of Firefox on a large number of computers for next month. Sometimes, this is not even possible (hello Windows 2000/XP users).

http://np237.livejournal.com/32133.html

So kann mans natürlich auch sehen. Allerdings glaub ich nicht, dass Google ewig für den Support von Firefox 3.5 oder auch bald 3.6 bezahlen will - und das zurecht. Gerade durch den neuen release cycle von Firefox, inspiriert von Chromium, wäre es für solche Desktop-Debianer angebracht, in puncto Browserversion (Firefox 3.6 für die nächsten 1,5 Jahre kann doch nicht ernst gemeint sein) umzudenken. Es muss doch nicht alles veraltete Software sein.

Mein Frontend-Entwicklerherz hat der Blogpost jedenfalls gewonnen.